Here are links to our latest python software packages. Note that these python packages are only the python interfaces. The core SasktranIF software  components are a separate installation from our software download page. Note that these wheels only support Python 3 on Windows x64. Linux users must build the entire distribution. Also note that we use numpy within the python interface and this will create issues if you use an earlier version of numpy in your version of Python. If you use anaconda python you can upgrade numpy with a console command like "conda upgrade numpy".

You can install the SasktranIF or OSIRIS Level 1 Services wheel into your python system with:

pip install <wheel filename>

Happy pythoning!

 

Pre-requisites

  1. You have to install the Core Level 1 Services before installing the osl1 python interface.
  2. You have to install the Core Sasktran Components before installing the sasktranif python interface

and you may have to install Visual Studio 2012 C++ x64 Redistributables if the libraries dont work.

Python 3.4

Windows, amd64/x64 built for python 3.4 with numpy version 1.8.2 or greater

  1. Python interface to Python SasktranIF Version 4.0.1.  You also need to install Core SasktranIF
  2. Python interface to Python Osiris Level 1 Services 2.48. You also need to install Level 1 Services

 

Python 3.5

Windows, amd64/x64 built for python 3.5 with numpy version 1.9.3 or greater

  1. Python interface to SasktranIF Version 4.0.4. You also need to install Core SasktranIF 
  2. Python Interface to Osiris Level 1 Services 2.48 You also need to install Level 1 Services